[ Java ][HackerRank] 30 Days of code Day 8


Day 8: Dictionaries and Maps


해커랭크 튜토리얼을 번역했습니다

Java Maps

Map은 key와 value로 쌍을 이루고 있는 데이터 구조를 위해서 청사진을 제공하는 interface 이며, key를 value에 연결시킵니다

(모든 key와 value는 반드시 객체(Object)여야 하며 primitives(가장 기본적인 동작)이지 않아야 한다는 것을 기억하는 것은 중요합니다)

이것의 구현은 HashMap이나 LinkedHashMap같은 클래스를 구현하면서 완료됩니다.

아래의 코드를 봐주세요:

// Declare a String to String map
//String map에 String을 선언합니다
Map<String, String> myMap;

// Initialize it as a new String to String HashMap
//String HashMap으로 새로운 String을 초기화 해줍니다
myMap = new HashMap<String, String>();

// Change myMap to be a new (completely different) String to String LinkedHashMap instead
//myMap을 새로운(완전히 다른)String이 되도록 String LinkedHashMap대신에 변경해줍니다
myMap = new LinkedHashMap<String, String>();

이 챌린지를 위해 필요한 몇 가지 Map methods들이 있습니다.

  • containsKey(Object Key) : 만약 map이 key를 위한 mapping을 포함하고 있으면 ‘참’을 반환합니다 : 그런 mapping이 없으면 ‘거짓’을 반환합니다
  • get(Object Key) : 매핑된 key의 value를 반환합니다 : 그런 mapping이 없을경우 null을 반환합니다
  • put(K key, V value) :Map에 key value매핑을 추가합니다 : 만약 key가 이미 map에 들어있다면, value는 덮어써지게 됩니다.

Task Given names and phone numbers, assemble a phone book that maps friends’ names to their respective phone numbers. You will then be given an unknown number of names to query your phone book for. For each queried, print the associated entry from your phone book on a new line in the form name=phoneNumber; if an entry for is not found, print Not found instead.

Note: Your phone book should be a Dictionary/Map/HashMap data structure.

Input Format

The first line contains an integer, , denoting the number of entries in the phone book. Each of the subsequent lines describes an entry in the form of space-separated values on a single line. The first value is a friend’s name, and the second value is an -digit phone number.

After the lines of phone book entries, there are an unknown number of lines of queries. Each line (query) contains a to look up, and you must continue reading lines until there is no more input.

Note: Names consist of lowercase English alphabetic letters and are first names only.

Output Format

On a new line for each query, print Not found if the name has no corresponding entry in the phone book; otherwise, print the full and in the format name=phoneNumber.

Sample Input

3
sam 99912222
tom 11122222
harry 12299933
sam
edward
harry

Sample Output

sam=99912222
Not found
harry=12299933

Explanation

We add the following (Key,Value) pairs to our map so it looks like this:

We then process each query and print key=value if the queried is found in the map; otherwise, we print Not found.

Query 0: sam Sam is one of the keys in our dictionary, so we print sam=99912222.

Query 1: edward Edward is not one of the keys in our dictionary, so we print Not found.

Query 2: harry Harry is one of the keys in our dictionary, so we print harry=12299933.


//Complete this code or write your own from scratch
import java.util.*;
import java.io.*;

class Solution{
    public static void main(String []argh){
        Scanner in = new Scanner(System.in);

        Map<String, Integer> myMap = new HashMap<String, Integer>();


        int n = in.nextInt();
        for(int i = 0; i < n; i++){
            String name = in.next();
            int phone = in.nextInt();
            // Write code here
            myMap.put(name,phone);
        }
        while(in.hasNext()){
            String s = in.next();
            // Write code here
            if(myMap.get(s) == null){
                System.out.println("Not found");
            }else{
                System.out.println(s + "=" + myMap.get(s));
            }

        }
        in.close();
    }
}









© 2018. by sora

Powered by sora